E语言接入

一、准备工作:首先在云端代码上添加事件 _login() 并启动。

1
2
3
4
string _login(string&in from, string&in msg)
{
    return "this is login return msg";
}

二、在 云工具 页面下载 Win开发组件并解压,这里可以看到3个目录:

备注:

include目录:win头文件

dll目录:win-lib和dll

json目录:如果要使用json解析可以导入这个包的文件到项目中

三、新建一个e语言项目,将 dllClient.dll 拷贝到项目目录中, 并插入dll命令

如图:

代码:

1
2
3
4
5
6
7
8
9
10
11
12
.版本 2

.DLL命令 Bovey_创建句柄, 整数型, "dllClient.dll", "Client_Malloc_E", 公开, 创建句柄

.DLL命令 Bovey_初始化网络, 逻辑型, "dllClient.dll", "Client_Init_E", 公开, 初始化网络
.参数 fd, 整数型

.DLL命令 Bovey_登录服务器, 文本型, "dllClient.dll", "Client_Login_E", 公开, json字符串(此接口触发服务器上的 _login 函数)
.参数 fd, 整数型, , 句柄
.参数 token, 文本型, , 云应用生成的标识符
.参数 custom_code, 文本型, , 自定义标识符
.参数 time, 整数型, , 登录超时时间

四、在e语言代码中执行登录操作(需要先创建句柄和初始化网络, 只需一次)

全局变量-句柄声明代码:

1
2
3
.版本 2

.全局变量 g_bovey_fd, 整数型, 公开, , 博维云组件句柄

创建句柄代码:

1
2
3
4
5
6
7
.版本 2

g_bovey_fd = Bovey_创建句柄 ()
.判断开始 (g_bovey_fd ≠ 0)
信息框 (“创建句柄成功, fd:” + 到文本 (g_bovey_fd), 0, , )
.默认
信息框 (“创建句柄失败”, 0, , )

初始化网络代码:

1
2
3
4
5
6
7
8
9
.版本 2

.局部变量 b, 逻辑型

b = Bovey_初始化网络 (g_bovey_fd)
.判断开始 (b = 真)
信息框 (“初始化网络成功”, 0, , )
.默认
信息框 (“初始化网络失败”, 0, , )

登录代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
.版本 2

.局部变量 token, 文本型, , , 云应用生成的标识符
.局部变量 custom_code, 文本型, , , 自定义标识符
.局部变量 str, 文本型, , , 返回数据
.局部变量 err, 文本型, , , 错误信息
.局部变量 code, 逻辑型, , , 返回值
.局部变量 data, 文本型, , , 返回数据

token = edit_token.内容
custom_code = edit_custom_code.内容
str = Bovey_登录服务器 (g_bovey_fd, token, custom_code, 60)
err = Bovey_获取错误信息 (g_bovey_fd)
code = Bovey_获取结果值 (str)
data = Bovey_获取结果数据 (str)

.判断开始 (code = 真)
信息框 (“登录服务器成功, SER:” + data, 0, , )
.默认
信息框 (“登录服务器失败, ERR:” + err, 0, , )